PSS®E Add-On Modules Evaluation Request

To request an evaluation copy of a PSS®E Add-On Module, please fill in the information below, and then click "Submit" at the bottom of the page.

 

PSS®E Add-On Modules Compatibility Requirements

Module
Requirements (for v33 users)
Requirements (for v34 users)
At least PSS®E 33.8
At least PSS®E 34.2 (August 2016)
At least PSS®E 33.8
At least PSS®E 34.2 (August 2016)
At least PSS®E 33.8
At least PSS®E 34.1 (May 2016)

At least PSS®E 33.8

At least PSS®E 34.1 (May 2016)
At least PSS®E 33.9 (May 2016)
At least PSS®E 34.1 (May 2016)
At least PSS®E 33.9 (May 2016)
At least PSS®E 34.1 (May 2016)
At least PSS®E 33.9 (May 2016)
At least PSS®E 34.1 (May 2016)
At least PSS®E 33.10
At least PSS®E 34.2